GraphStream Users

Archives de la liste Aide


Maven compile error


Chronologique Discussions 
  • From: <michalk AT awpi.com>
  • To: graphstream-users AT litislab.fr
  • Subject: Maven compile error
  • Date: Fri, 29 Jul 2022 21:13:00 +0200 (CEST)

I am trying to build gs-core 2.1.0-SNAPSHOT with maven 3.6.3, java 11.0.16,
and
am getting an error:

[INFO]
------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 5.588 s
[INFO] Finished at: 2022-07-29T13:42:44-05:00
[INFO]
------------------------------------------------------------------------
[ERROR] Failed to execute goal org.jacoco:jacoco-maven-plugin:0.8.5:report
(default-report) on project gs-core: Execution default-report of goal
org.jacoco:jacoco-maven-plugin:0.8.5:report failed: A required class was
missing while executing org.jacoco:jacoco-maven-plugin:0.8.5:report:
org/codehaus/plexus/util/xml/XmlStreamReader
[ERROR] -----------------------------------------------------

Can anyone else validate this problem? I can't upgrade Maven at this time due
to apt package dependency problems on my machine.

I want to make org.graphstream.stream.SourceBase.manageEvents() syncronized.
I
think the non-atomic operation with the boolean test is causing problems.


  • Maven compile error, michalk, 29/07/2022

Archives gérées par MHonArc 2.6.16.

Top of page